All pastes #768998 Raw Edit

Stuff

public text v1 · immutable
·published 2007-11-11 01:11 UTC
rendered paste body
FAIL	
Missing (stealth) nameservers	FAIL: You have one or more missing (stealth) nameservers. The following nameserver(s) are listed (at your nameservers) as nameservers for your domain, but are not listed at the parent nameservers (therefore, they may or may not get used, depending on whether your DNS servers return them in the authority section for other requests, per RFC2181 5.4.1). You need to make sure that these stealth nameservers are working; if they are not responding, you may have serious problems! The DNSreport will not query these servers, so you need to be very careful that they are working properly.

ns2.xlab-group.com.
ns1.xlab-group.com.
This is listed as an ERROR because there are some cases where nasty problems can occur (if the TTLs vary from the NS records at the root servers and the NS records point to your own domain, for example).





FAIL	

Missing nameservers 2	ERROR: One or more of the nameservers listed at the parent servers are not listed as NS records at your nameservers. The problem NS records are:
ns3.xlab-group.com.
ns4.xlab-group.com.






WARN	

Nameservers on separate class C's	WARNING: All of your nameservers (listed at the parent nameservers) are in the same Class C (technically, /24) address space, which means that they are probably at the same physical location. Your nameservers should be at geographically dispersed locations. You should not have all of your nameservers at the same location. RFC2182 3.1 goes into more detail about secondary nameserver location.






FAIL	

Stealth NS record leakage	Your DNS servers leak stealth information in non-NS requests:

Stealth nameservers are leaked [ns2.xlab-group.com.]!
Stealth nameservers are leaked [ns1.xlab-group.com.]!

This can cause some serious problems (especially if there is a TTL discrepancy). If you must have stealth NS records (NS records listed at the authoritative DNS servers, but not the parent DNS servers), you should make sure that your DNS server does not leak the stealth NS records in response to other queries.






WARN	

SOA MNAME Check	WARNING: Your SOA (Start of Authority) record states that your master (primary) name server is: ns1.xlab-group.com.. However, that server is not listed at the parent servers as one of your NS records! This is legal, but you should be sure that you know what you are doing.





WARN	

SOA EXPIRE value	WARNING: Your SOA EXPIRE time is : 3600000 seconds. This seems a bit high. You should consider decreasing this value to about 1209600 to 2419200 seconds (2 to 4 weeks). RFC1912 suggests 2-4 weeks. This is how long a secondary/slave nameserver will wait before considering its DNS data stale if it can't reach the primary nameserver.






WARN	

SPF record	Your domain does not have an SPF record. This means that spammers can easily send out E-mail that looks like it came from your domain, which can make your domain look bad (if the recipient thinks you really sent it), and can cost you money (when people complain to you, rather than the spammer). You may want to add an SPF record ASAP, as 01 Oct 2004 was the target date for domains to have SPF records in place (Hotmail, for example, started checking SPF records on 01 Oct 2004).