;sip.conf
;
; SIP Configuration for Asterisk
;
; Syntax for specifying a SIP device in extensions.conf is
; SIP/devicename where devicename is defined in a section below.
;
; You may also use
; SIP/username@domain to call any SIP user on the Internet
; (Don't forget to enable DNS SRV records if you want to use this)
;
; If you define a SIP proxy as a peer below, you may call
; SIP/proxyhostname/user or SIP/user@proxyhostname
; where the proxyhostname is defined in a section below
;
; Useful CLI commands to check peers/users:
; sip show peers Show all SIP peers (including friends)
; sip show users Show all SIP users (including friends)
; sip show registry Show status of hosts we register with
;
; sip debug Show all SIP messages
;
[general]
pedantic=no
context=inbound ; Default context for incoming calls
;recordhistory=yes ; Record SIP history by default
; (see sip history / sip no history)
;realm=mydomain.tld ; Realm for digest authentication
; defaults to "asterisk"
; Realms MUST be globally unique according to RFC 3261
; Set this to your host name or domain name
port=5060 ; UDP Port to bind to (SIP standard port is 5060)
bindaddr=0.0.0.0 ; IP address to bind to (0.0.0.0 binds to all)
srvlookup=yes ; Enable DNS SRV lookups on outbound calls
; Note: Asterisk only uses the first host
; in SRV records
; Disabling DNS SRV lookups disables the
; ability to place SIP calls based on domain
; names to some other SIP users on the Internet
; and multiline formatted headers for strict
; SIP compatibility (defaults to "no")
;tos=184 ; Set IP QoS to either a keyword or numeric val
;tos=lowdelay ; lowdelay,throughput,reliability,mincost,none
;maxexpirey=3600 ; Max length of incoming registration we allow
;defaultexpirey=120 ; Default length of incoming/outoing registration
;notifymimetype=text/plain ; Allow overriding of mime type in MWI NOTIFY
;videosupport=yes ; Turn on support for SIP video
disallow=all ; First disallow all codecs
allow=ulaw ; Allow codecs in order of preference
allow=gsm
allow=ilbc ; Note: codec order is respected only in [general]
musicclass=default ; Sets the default music on hold class for all SIP calls
; This may also be set for individual users/peers
language=en ; Default language setting for all users/peers
; This may also be set for individual users/peers
;relaxdtmf=yes ; Relax dtmf handling
;rtptimeout=60 ; Terminate call if 60 seconds of no RTP activity
; when we're not on hold
;rtpholdtimeout=300 ; Terminate call if 300 seconds of no RTP activity
; when we're on hold (must be > rtptimeout)
;trustrpid = no ; If Remote-Party-ID should be trusted
;progressinband=yes ; If we should generate in-band ringing always
;useragent=Asterisk PBX ; Allows you to change the user agent string
;nat=yes ; NAT settings
; yes = Always ignore info and assume NAT
; no = Use NAT mode only according to RFC3581
; never = Never attempt NAT mode or RFC3581 support
; route = Assume NAT, don't send rport (work around more UNIDEN bugs)
;promiscredir = no ; If yes, allows 302 or REDIR to non-local SIP address
; ; Note that promiscredir when redirects are made to the
; ; local system will cause loops since SIP is incapable
; ; of performing a "hairpin" call.
;
; If regcontext is specified, Asterisk will dynamically
; create and destroy a NoOp priority 1 extension for a given
; peer who registers or unregisters with us. The actual extension
; is the 'regexten' parameter of the registering peer or its
; name if 'regexten' is not provided. More than one regexten may be supplied
; if they are separated by '&'. Patterns may be used in regexten.
;
;regcontext=iaxregistrations
;
; Asterisk can register as a SIP user agent to a SIP proxy (provider)
; Format for the register statement is:
; register => user[:secret[:authuser]]@host[:port][/extension]
;
; If no extension is given, the 's' extension is used. The extension
; needs to be defined in extensions.conf to be able to accept calls
; from this SIP proxy (provider)
;
; host is either a host name defined in DNS or the name of a
; section defined below.
;
; Examples:
;
;
;
; This will pass incoming calls to the 's' extension
;
;
;register => 2345:password@sip_proxy/1234
;
;register => <user id>:<password>@switch-1.asterlink.com/<user id>
;
; Register 2345 at sip provider 'sip_proxy'. Calls from this provider connect to local
; extension 1234 in extensions.conf default context, unless you define
; unless you configure a [sip_proxy] section below, and configure a context.
; Tip 1: Avoid assigning hostname to a sip.conf section like [provider.com]
; Tip 2: Use separate type=peer and type=user sections for SIP providers
; (instead of type=friend) if you have calls in both directions
;externip = 200.201.202.203 ; Address that we're going to put in outbound SIP messages
; if we're behind a NAT
; The externip and localnet is used
; when registering and communicating with other proxies
; that we're registered with
; You may add multiple local networks. A reasonable set of defaults
; are:
;localnet=192.168.0.0/255.255.255.0; All RFC 1918 addresses are local networks
;localnet=192.168.1.0/255.255.255.0
;localnet=10.0.0.0/255.0.0.0 ; Also RFC1918
;localnet=172.16.0.0/12 ; Another RFC1918 with CIDR notation
;localnet=169.254.0.0/255.255.0.0 ;Zero conf local network
;-----------------------------------------------------------------------------------
; Users and peers have different settings available. Friends have all settings,
; since a friend is both a peer and a user
;
; User config options: Peer configuration:
; -------------------- -------------------
; context context
; permit permit
; deny deny
; secret secret
; md5secret md5secret
; dtmfmode dtmfmode
; canreinvite canreinvite
; nat nat
; callgroup callgroup
; pickupgroup pickupgroup
; language language
; allow allow
; disallow disallow
; insecure insecure
; trustrpid trustrpid
; progressinband progressinband
; promiscredir promiscredir
; callerid
; accountcode
; amaflags
; incominglimit
; restrictcid
; mailbox
; username
; template
; fromdomain
; regexten
; fromuser
; host
; mask
; port
; qualify
; defaultip
; rtptimeout
; rtpholdtimeout
;{providers}
;[sip.broadvoice.com]
;permit=147.135.0.128/30
;type=friend
;host=sip.broadvoice.com
;fromdomain=sip.broadvoice.com
;fromuser=
;secret=
;username=
;insecure=very
;context=inbound
;authuser=
;authname=
;dtmfmode=inband
;dtmf=inband
;qualify=yes
;inscure=very
;maxexpirey=15
;nat=yes
;canreinvite=no
;disallow=all
;allow=ulaw
;allow=gsm
;allow=ilbc
;allow=g726
;allow=g729
;[sipphone]
;type=friend
;secret=
;username=1747
;fromuser=1747
;fromdomain=proxy01.sipphone.com
;host=proxy01.sipphone.com
;context=default
;disallow=all
;allow=ulaw
;[asterlink]
;type=peer
;host=switch.asterlink.com
;username=<your numerical user id>
;fromuser=<your numerical user id>
;secret=<your password>
;disallow=all
; We allow pretty much any codec you can throw at us but g726 is good
;allow=g726
;[asterlink-switch-01]
;type=peer
;host=switch-01.asterlink.com
;context=default
;insecure=very
;[asterlink-switch-02]
;type=peer
;host=switch-02.asterlink.com
;context=default
;insecure=very
;[asterlink-switch-03]
;type=peer
;host=switch-03.asterlink.com
;context=default
;insecure=very
;[asterlink-switch-04]
;type=peer
;host=switch-04.asterlink.com
;context=default
;insecure=very
;[asterlink-switch-05]
;type=peer
;host=switch-05.asterlink.com
;context=default
;insecure=very
;[asterlink-switch-06]
;type=peer
;host=switch-06.asterlink.com
;context=default
;insecure=very
;[asterlink-switch-07]
;type=peer
;host=switch-07.asterlink.com
;context=default
;insecure=very
;[extenions]
;[1001]
;type=friend ; Friends place calls and receive calls
;context=admin ; Context for incoming calls from this user
;secret=1234
;host=dynamic ; This peer register with us
;dtmfmode=rfc2833 ; Choices are inband, rfc2833, or info
;dtmf=rfc2833
;username=1001 ; Username to use in INVITE until peer registers
;mailbox=1001
;nat=yes ; X-Lite is behind a NAT router
;canreinvite=no ; Typically set to NO if behind NAT
;callerid= Name <nmbr or exten>
;disallow=all
;allow=ulaw ; dtmfmode=inband only works with ulaw or alaw!
;allow=gsm
;allow=ilbc